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Agenda

% PDM Beginnings & How to start in RSE

% Table View

% Running commands

% Compiling

% Searching iSeries files

% Basic editing with SEU & LPEX

% LPEX Syntax checkers, verifiers and outline views
% Other LPEX tricks & features

% Comparing source

+% Questions

© 2006 IBM Corporation




% There are two ways to start PDM:
» STRPDM, or

» WRKxxxPDM commands

% Only the last entries are
remembered

% Work with multiple programs,
libraries etc, you might have more
than one emulator running so you
can work with all your items at the
same time

o

=10l x|

[12" [1902 - Session successfully started 4

R
Work with Members Using PDM (WRKMBRPDM)

Type choices, press Enter.

Bottom
F3=Exit F4=Prompt F5=Refresh F12=Cancel F13=How to use this display
F2d4=More keys

05/037
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How to begin in RSE

% When you first start WDSC
workbench, you will be prompted
for a workspace. This is where all
the definitions of your RSE
preferences and workbench
configuration information and files
will reside.

% Once the workbench is started,
ensure that you are in the Remote
System Explorer Perspective

» Window->Open Perspective-
>Remote System Explorer

% Next you will need a connection...

---- iSeries. ..
B Windows. ..
& £y Linux. ..

ﬁ Paweer Limas,
Fl-UHEE LN, .
-5, ALE...

#-E] Local...

]E? Local
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Creating a connection

% Expand the iSeries icon in the New ";:;,j’::;:‘;;;’j‘;e
. . 4
Connection Filter S ————————
% Leave the default profile name R R
% Specify host name and connection
name
% Ensure Verify connection is
selected
% Push Finish

Remote iSeries System Con

ection
Define connection information !

parert profile; | viokaine |
Connection name: | TORASIPM

Host name: [ToRaszPM |
Descriptio |

[V werify host
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Subsystems

% Expanding a connection lists the
subsystems within that connection:

» Objects: used to access libraries,
objects and members

» Commands: predefined commands
you can use to run against remote
objects. You can also define
command sets. Results are logged
in the Commands log view

» Jobs: display various jobs, subset
by job attributes, and perform job
operations

» IFS Files: explore IFS file an folder
structure and perform actions on
them.

» Qshells: lists the active running
gshells for the connection

N ; Remoke Swstems M

=ﬁ.g"al: :4a|<}:§v

[F-_4° MNew Connection

<

ﬁ, Pawer Linux,.,
-t Ui,
B AN
&=-BE Local...

[]---E_f Local

Elﬁ@ iSeries Objects

-8, iSeries Commands
E]—--ﬁn iSeties Jobs
[Ty IFS Files

E?i iSeries...

e[| Connection crested succassFully,
- windows, ..

ﬂ Linux,..,

-2 work with libraries. ..
1'.3 Work with objects. ..
1'.5 ‘Work with members. ..
ﬁ Library list

% User libraries

- [@ Qshells
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Filters
% Filters are named lists of items that 3J
. J
you can specify, reuse and share. P m—
% Expanding the Work with... items e
opens the appropriate filter
creation dialog
% Specify the list of libraries, objects, e
or members you want RSE to
retrieve. ' N
% Give the filter a name =7
% Choose whether or not you want
the filter to be only for the specified
connection
% Choose whether or not you would
like to share the filter with others
bk | text> [ B | conce
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Filter Strings

% When first created, a filter is created with only one filter string
% By modifying the properties of a filter, you can add additional filter strings

» In PDM you could only list the members in one source physical file in one library.

» In RSE you can use filters and filter strings to list members in different files and
even in different libraries.

% In PDM only the last WRKxxxPDM setting is remembered. In RSE all filters
are persisted between sessions.
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RSE Tree View

% Filters appear in the tree view

% Drill down like File Explorer in
Windows

% Drag & drop, copy, paste, delete
rename actions

% Actions appear in popup (right-
click)

i "y
ﬂRemote Systems &4 . Team =0

L @05 -
=ﬁ MNew Connection
#H-E] Local

=B TorassPm

L——_IEE iSeries Ohjects
1'.; Wark with libraries. .,
A7 work with objects. ..

iﬁ ok with members. ..

EI% Library list
- m), QFYS, M. prad-sys
-, QSYS2 *ib.prod-sys
(-, QHLPSYS. *lib.prod-sys
I\. QUSRSYS. *lib.prod-sys
- BATTHISH. *lib. prod-cur
I\. QGPL. ¥k, prod-usr
-2, QTEMP. it test-usr

[]---% User libraries

F-E¢ MY objects in MYLIE

[]---% Application 1

].: iZeries Commands

[]---a iSeties Jobs
H-T¥ 1FS Files

ﬁ Qshells
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Table View

% More comfortable interface for PDM users

% Launch table view from RSE Tree view by using the Show in Table View
action

% Use the Work with menu option to access list same way as you would using
the WRKxxxPDM commands

% Work with menu keeps a small list of previously displayed lists specifications

ra st Y
Remoke System Details | Tasks [z e oo R TEAM, iSeries Commands Log S O oy v B H
Filter 'Library list' (7 Objects) Lbraries... | workwith b
Mame | Type | Abtribute Objects... - _I_I_I-
: ubset. ..
SRS LB PROD-5Y5 Wembers... o
552 *+LIB PROD-5YS "
ggHLPS\"S R PROD-GY5 Objects: BATTHISH <TORASIPM:> Show columns — #
v Filcer: Library list <TORASIPM= Easition ko, . .
ﬂ.QUSRS\"S *+LIB PROD-5YS
I’:BATTHISH *LIE PROD-CUR Wiolaine Batthish/batthish@ca.ibm,com Print...
B OGRL *+LIB PROD-USR General Purpose Library Export ko File,..
=L QTEMP *LIB TEST-LISR. Hide Commands
4 | Preferences. .. _;I
L 4
Command INormaI j I j Bromipt... | Fun |
Messages I d Debails. .. | Show Log |
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Table View Actions

% Use the Show in Table action from inside Table View to go from a list of
libraries to a list of objects etc.

% A list of familiar PDM Options

% Use the User actions menu to create and add your own actions

% Double click on member to edit it
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User Actions (F16)

% Define your own action

% Prompt the command to define and
also optionally when executing

% Use the same substitution
variables as PDM and several
more

% Specify if the action should refresh
the views

% Specify when action applies when
a single object is selected

% Specify Invoke once to group the
items into one command execution

% Refine them to apply to the
appropriate types (add your own)

& Work With User Actions

Parent profile: Iviolaine

b E‘é" Object action

- qﬁ Member action

W
BT Action name:

|
|
I My Action
Comment: I This runs my action
Command: INormaI command

B il

CLRLIE QTEMP|
1

Insert variable. .. |
Prompt. .. |

™ Prompt firsk
[™ single selection only

Edit... Browse. .. I

I Refresh after W Show ackion
I Irwoke once

Resource bypes for which this action will appear

Defined Types Selected Types
Add>

CMD

FILE <RemovelE]

FILE_DATA .

FILE_DSPF Edit(H). .

FILE_MEBRS

FILE_FRTF ;|
ALL: *

Create I Revert() I
Close |
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Command Line

Remate System Detsils Table View X iSeries Commands Lng|

Library BATTHISH (25 Objects)
e

. - =0

N [ Type [ attribute | Text [ Stat [ ]
[ELpip12 HEILE SavE oK
GDOMFILEL FILE DDMF REMOTE DDM KEYED FILE oK
[El oovFLE2 FILE PF-DTA oK J
[Elevrevent FILE FF-DTA oK
[EH *EILE PF-SRC aK
Gj1saaiD FILE DsPE oK
Nt FILE SaVE oK
5 prRsas2s FILE SavE oK _Iﬂ
4 | »
~

Command [Marmal =] [sctie scipstest

| erompt... | Run

Messages [Library ECLIPSTEST aready exists in lbrary list,

7| petals... | show Log

addiible eclipstest
Library ECLIPSTEST already exists in library list.
IPSTES

ause ... i The library already exists in the library ot added. Recovery . .. : IFECLIPSTES
you specified omit the command. TF you did not specify library ECLIPSTEST then change the ibrary name (LIB patameter). Then bry the command again.

Command [ormal Eafl]

[

STEST alread: he library search lit. The library was T is the library

=] Erompe... E‘

% Use the command line to run any command

% Specify additional parameters for PDM Options
% Results displayed in the messages field

% Use familiar keys:

» F9: repeat last command

» F4: prompt command

% Use the Show Log button to view iSeries commands Log view.
% Use the STRRSESVR command to handle interactive commands
% Batch option uses the SBMJOB command
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Compiling (option 14,15)

% Compile actions are grouped in two
menus (with and without
prompting)

% Users can add their own
commands to the compile
commands

% Compile actions are different from
other actions:

» Results of the command itself
appear in the Command Log

» Errors appear in the Error List

.
VIeW Remots System DEtaMs‘Tasks|\Series Table Wiew | i5sries Commands Log [B [ e

TORASIPM:BATTHISH/EVFEVENT(TEST)

® %

v

=0

ine | Location

| connection

% Additional command execution B

[ RMFO257

i

preferences can be found in the |
Window->Preferences->Remote
Systems->iSeries->Command
Execution preference page (F18)

BATTHISH/QRPGLESRCITE. ..

BATTHISH/QRPGLESRC(TE.

BATTHISH/QRPGLESRC(TE. ..
BATTHISH/QRPGLESRCITE. ..
BATTHISH/QRPGLESRC(TE. ..

TORAS3PM
TORASIPM
TORASIPM
TORAS3PM
TORASIPM
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Searching (Option 25)

% Two ways to search: s E——
» Search->iSeries menu

» Find String... action

% Search filters, not just libraries,
files, members. This means that
you can create very flexible search R ———
patterns. :

% Results appear in the Remote o] o |
Search view.

% Double click on a result to open the
member in Remote Systems LPEX
Editor and position to the match CmEnom L

(Line 252) D ZIPTEST 5 1A
% The popup menu for the members o
. . . . . (L?na 921) DOW (zmjsﬂ : HON);
E::::Z :ig i;;f:;;o?:&nuu DUE TO KNOWN ABBREVIATIONS: 2

{ 3 *
Line 935) ZIPTEST = *OFF;
table view (rename, move, etc) - e

I Il o {Line 950) ZIPTEST = *OFF;
Line 957 ZIPTEST = *QFF;

* V i eW h a S a h i Sto ry Of Se a rC h es ELInE 935) ** &~TESTMUMERIC - TEST ALL NEEDED FIELDS FOR NUMBER. ¥ALUES LI
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+% From RSE, or Table view:
» Double-click
» Open (option 2), or
» Browse (option 5) using menus
% Tokenization: the colouring of
language tokens
% Prefix area: can use all the SEU
commands
% Show date: use the context menu
% Outline view: shows the outline of
your program. Used to navigate
within your program

A FTEST RPGLE 32

Line 18

ooooo1
nooooz
000003
000004
ooooos
[a]u]u]uln})
ooooo?
0oooos
[a]ulu]uln}=]
oooo10

[a]ulu]ub N
oooo17
000018
a0001s9
oooozo
noooz 1

a000zz #*
000023 COMPILE

0000z 4
000025

TIME
ARRAY

=]

Column 1 Replace 2 changes
[>T NO1NOZNO3F ie ld+++++++++¥B . End++PConstant/ Editwore

H DFTHAME (PROOF)

FOSYSPRT =] F 13z PRINTER
D ARRAY E 8 DIMi3)
o CTDATL PERRCD(1)
D INSTALL [+ CONST (' INSTALLATION' )
D DS D3
o 0K 1 =l INZ('VERIFIED')
C EVAL OFK = 'FAILED'
5 lines excluded. —————
o 24 'OF!'
o 28 'THE'
[s] 36 'ILE RFG'
o 45 'COMPILER'
o + 1 '13"
[s] QK + 1

@ -

B[ Files
i svseRT
-G Data Structur
: [0os

T ok char

=L@ Constants

. E-@ INSTALL

® 15

E-L 3 Indicators
E-[5] *INR
e
L[] *INOA

(g5 Main Procedure
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Remote Systems LPEX Editor vs SEU Basics

% SEU % Remote Systems LPEX Editor
» Full screen mode when browsing » Full screen mode for both edit and
(F13) browse: double click on editor tab
» Split screen and browse » Split screen for edit and browse:

there are two options

°Drag and drop the editor tab to
view two different members

*Use editor popup or Ctrl+2 to
split the current LPEX view to
work with different parts of the
same member (up to 5 splits)

» Date appears next to sequence
» Date area: at the right numbers. Can be enabled by a
preference or by popup

» Print: from File Menu or Ctrl+P
» Print: STRSEU and Option 6

© 2006 IBM Corporation
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Split Screens And Date Area

|/ TEST RPGLE 52 B8
BATTHISH|
Coluwn 18 Replace Replace
......... 1....+..I.2....+....3 .....O.............INEIINDZNEISF
ooooo1 H DFTWAME (PROCF) j ooonils O ;I
oooooz FOSYSPRT o] F 132 ooooi1s o]
000003 000020 o}
ooooog I ARRAY 3 o000z 1 o]
ooooos o ooooz22 +*
000006 I INSTALL C Oo000z3 COMPILE J
aoooo? oL D3 o3 ~|[0000Z4 TIME =
|
| # DOMFLLEL PF 52 =l
Line 5 Colwon 14 Replace
............ I . o JMame4++++++RBLent++ThpE. . . .. . Functions++4+4+4+-
000100 05712720 E FHMT1
aoo101 Os5/12/20 FIELD1 10
Q00102 05712720 FIELDZ 10
000103 05712720 FIELDS 10
aoo104 O5/12/20 FIELD4 10
Q00105 05712720 K FIELD

e L |

DOMFILEL,PF

21, ML

FIELD1 10
FIELDZ 10
FIELDS 10

FIELD4 10

FIELD

[+
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Syntax Checking, Help & Prompting

. A HTEST.RRGLE 52 8
* RS E y I I ke S E U h as a utO'SyntaX RemotesystemsTempFles/TORASIPMIQEYS LIBIEAT THISH LIE/QRPGLESRC  FILE/TEST. RPGLE
l—Dmmmvmll ..... - S b
h k' 000004 D ARRAY E g DIN(3) -
C eC Ing 000005 D CTDATA PERRCD (1)
000006 D INSTALL B CONST | ' TNSTALLATICH' )

[nlnfalululrs o D3 o3

» See all the errors, not just the first oooooe v o i a meevmm

FNF371ZE To-Field-Location entry is not wvalid; defaults to From-F:
one FNF3431E Length of initial walue exceeds size of field.
ooooo=
oooo1o C EVAL OK = 'FAILED'

% Help (F1) is available for the errors, e WO N vt A b R

FNF330ZE The Data-Type entry is not wvalid; defaults to hlank.
but aISO for the Sou rCe' FNF3708E From-Field-Location entry is not wvalid: defaults to 1.
- FNF3712E To-Field-Location entry is not valid; defaults to From-F:
. . FHNF3414E The Decimal-Positions entry i=s not walid; defaults to hle
» Context sensitive help directly

. | eyword name is not walid; the kEylmrdI is ignored. _.'Ll
linked to the reference manuals ,

» Manuals quickly accessible from
the Source menu
% Prompting (F4) appears either in . e
the iSeries Source Prompter view e N

o a=s

or (for CL) in a dialog. F1 context
sensitive help available from the
prompt view or the CL prompter.
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Verifiers & Error List

P b b P

)

COBOL, RPG & DDS have a program
verifier (Ctrl+Shift+V)

Syntax & semantic checking (no code
generation)

Verifiers generate the same error
messages as the compiler

Use Source->Verify (Prompt) to specify
additional options or modify default
verify preferences.

Errors appear in the Error List View as
for compile.

» Insert errors into source
» F1 help for errors

» Filter errors

» Use as a TODO list

» In editor,

*use Ctrl+F5 to Refresh (removes all
errors, clears any excluded lines), or

*Source->Remove messages to
remove errors

Colurn 41 Replace 3 changes

P B B . P T F - P S PR
RNS9303: Compilation stopped. Sewverity 30 errors found in progrsam. =
ooooo1 H DFTHMAME (PROOF)
ooooonz FQSTIPRT e} F 13z FRINTER

ENF2318: Overflow indicator *INOA is assigned to PRINTER file Q3YSPRT.
[u]ulululuk]
onooo4 I ARBAY ) g DIN(3)

BHNF7031: The name or indicator ARRAY is not referenced.

0oooos o CTDATA PERRCD (1)
000006 I INSTALL s COMST (' INSTALLATICN' )
FHNF7031: The nawe or indicator DS is not referenced.
000o00& o 0K 1 i INZ('VERIFIED') —

RNF3712E To-Field-Location entry is not walid; defsults to From-Field-Locat
BNF3431E Length of initial walue Exceedslsme of field.
[alulululu}=]
oooo10 C EVAL OK = 'FAILED'
000011 asffatd HOVE ARRAY (2} ARRAT (3}
RNFO2Z57: Form-Type entry for main procedure not wvalid or out of seguence.
oono1z [

RESET oK -
4 | LI_I

Remote System D, .. | Tasks | iSeties Table View | iSeties Comman... (@isaries Ertor List £3 Remote Search | iSeries Source P, | =3

TORASIPM:BATTHISH/EWFEYENT(TEST) F3 & : a
| I j(5] I Message | Sev... | Line | Location
RNS9308 Compilation stopped, Severity 30 errors found in progran. 50 [1} BATTHISH/QRPELESRC(TE.
+ [ RNFOZS7 Form-Type entry for main procedure not walid or out of seq... 30 11 BATTHISH/QRPELESRC(TE. .
i RANFz31E Overflow indicator ¥INOA is assigned to PRINTER file QSvS... 00 2 BATTHISHJQRPGLESRC(TE..
i RNF7O3 The name o indicator ARRAY is not referenced, i} 4 BATTHISH/QRPELESRC(TE.,
i rnF7OH The name or indicator D5 is not referenced, i} 7 BATTHISH/QRPELESRC(TE.
. ]
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Content assist and Templates

e x N ) e

nnnnnn Column 36  Replace 6 changes ]
..... CLONOLFRETOLE 1H++++++0pr0de (E) HJACTOr2 ++++++HRESUIT +++++t+rLen+t+D+HILOE]. « . . CONMERTS +t-+-t

000001, H DFTIVANE (FROOF v
nnnnnn FQSYSPRT O  F PRINTER = .
nnnnnn ?ﬁ‘
nnnnnnnnnnnn pIn(s) oo
nnnnnn D CTDAT PERRCD (1) Torites e |
000006 D INSTALL c CONST(' INSTALLATICN' ) Expor.
000008 D 1 & INZ('VERTFIED') S
000009 ——
000010 c EVIL OK = 'FAILED'
000011 E HOVE he ST conbe. n2ke o i _owbed |
nnnnnn c RESHT appay ARRAY .
nnnnnn c SET 1
DDDDDD S 1w e s
nnnnnn o R
000016 o e
000017 o
000018 o
000013 o
nnnnnn o
nnnnnn o oK + 1
nnnnnnnn e[
nnnnnnnnnnn
000024 TIHE
000025 ARRAT (el o] o |

% Content assist (Ctrl+Space): propose, display and insert code completions at
the cursor position

» Can be used to provide context information
» RPG: Refresh the outline view

% Templates: type the name of the template and press Ctrl+Space
» Add your own templates
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RPG Wizards

% Three RPG wizards available to
facilitate programming:
» D Specification Wizard

» Procedure Wizard

» Java Method Call Wizard

% Accessed via Source menu or by
popup in source and selecting
appropriate option in the New
submenu

% Specify all needed information
using a graphical interface and
source is then generated
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Additional LPEX parser options and features

% Preferences
» Column sensitive editing

» Signatures

» Auto-uppercasing
» Auto-indent

» Auto-formatting

» Enter Key behaviour
% Parser specific functions:
» Open copy member/book

» Convert to free form (RPG)
» Convert to ILE (RPG)
» Show indentation (RPG)

Remate Syste... |Tasks | iSeries Tabl. .. ‘iSeries Com... |iSeries Error... | Remakte Search | iSeries Sour... w
-

AEO00Z.RPGLE

Line 142 Column &9 Insert Erowse

I 1 2 3 6-———+———F————+-——-8-———+
[P ————- INPUT SECTION®#Arsshantsnts =
o PR L T Ty

s} INPSTH BEGSR =

o} INle | DOWER 1

i FINGO | | CASEQ ol INFHD

© #IN30 | | CASEQ '1 INF1i0

o} | | END

C | ENDDC

s} INPEET ENDSR
o R R T ] _ﬁl
| 3
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Compiling from Remote Systems LPEX

% Ctrl+Shift+C runs the default compile command

% Toolbar button for compiling

% Toolbar buttons for next (Ctrl+Shift+H) and previous error (Ctrl+Shift+Y)
% Compile menu is available to select

% Must be connected to compile

PRINTER
iz assi

E DIN(3)
is not referenc
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Jobs

% Use the tree view to see jobs

% Add to the iSeries Job Status view
by job, or by default using the
preferences

% Access job information, properties
using popup

% Perform other basic operations
such as end, display job log

% Debug and add user actions too

; Remote Systems X Team| =08

=]f_ng|: :-:}|<;=='=>v

Remote Syskem Details | iSeries Table Wiew ‘ i5eries Commands ... ‘ iSeries Error List ‘ Remate Search | iSeries Source Pra.., | iSefies Indent ‘ 15eties Job Log rﬁn\liSeMes Jub Status 23
Date/Time Submitted | 30k | connection | status | Task |
10-Apr-2006 10:55:00 AM 522220(QUSER/QRWTSRYR  TORASIPM *ACTIVE

kil * [Refiresh Interval: Never

[
[

-8 iseries Jobs

gy Active jobs

EI% My active jobs

E-E8 QUSRWREK
[ 522220/QUSER{QRWTSRYR
L[ 522570/QUSER [QZRCSRYS

[—]39 My jobs
a-

g—ﬂ' Cther jobs
522551 /BATTHISH/EATTHISH
- [@] 522553(BATTHISH QP ADEVOIODE
. [@ 595972/BATTHISH,QPRTICE
]% My host server jobs
]% My WebFacing jobs

g My Visualage RPG DDM jobs
H-TF IFS Files
5 Qshells
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Search and Replace in LPEX

% Ctrl+F bring up the Find function in LPEX (ctrl

% Specify search string, and optionally replace string

% Specify Regular expression to allow you to search for a pattern:
» this|that (search for this or that)

% Ensure column sensitive editing is on, if you don’t want your text shifted
% Use Ctrl+N or Shift+F4 to find next match

& Remote System Explorer - TEST.RPGLE - IBM Rational Software Development Platform

Ele Edit Source

I-Bals-0-a-ls5ve-0 -0

Line S

000001
00000z
[alululululc)
000004
00oo0s
ooooos
000007

Trapped.

Compile Mavigate Search Project Run Window Help

meESTz.RPG |/ANNETE5T.RPGLE |/AEUUUZ.RPGLE ‘
n n

..... N - Y T

COMST (' INSTALLATION' )

Find [ ctdatal

Replace I

™ Case sensi tive [~ whole word [~ Regular expression W wirap [ Select Found text
I Restrict search to selection [ Restrict search to columns Start column [1 End column | 80
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Printing (Option 6)

% Ctrl+P, print button, File->Print
% Various print options can be found

In
» Window->Preferences->LPEX S .
Editor->Print o o |
% Note that line numbers are not the S O
same thing as sequence numbers |
% Substitution variable allowed in the N
EN
header & fOOter: IPage%p Document: %en Printed on %ed %t
» %p: page number '
» %n: source name, base file name,
or document name sl et W
» %f: full-path file name or document .
name
» %d: date
» %t: time
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Compare (Option 54)

% Open member
» Edit->Compare->Compare to file

» Compare button in toolbar
Source appears merged with differences
flagged in different colours
Only permitted to modify the source that
is opened
Ctrl+Shift+N for next mismatch
Ctrl+Shift+P for previous mismatch
Specify any preferences in LPEX:

» Columns to include

PP ¢ P

» Ignore sequence numbers

» Ignore blanks
Ctrl+Sift+R to refresh the compare
Edit->Compare->Clear to end

P b

{®iRemote System Explorer - TEST.RPGLE - IBM Rational Software Development Platform’

File Edit Source
Its-Baels-0-a- |+ |

m/TESTZ.RPG ‘/ANNETEST‘RPGLE ‘/AEUDBZRPGLE |

Replace 2 changes
B | . P T - O B Tk I T TRy - PR

Line 5

000001
00000z
000003
000004
00o00s
000006
000008
000007
000008
000003
000010
000011

Compile Navigate Search Project Run Window Help

COMST (' INSTALLATION' |
COMST{' INSTALLATION' )

geset | RestorsDefauks|  apply
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Additional Useful LPEX Keys

Ctrl+Home Go to the top
Ctrl+End Go to the end
Ctri+L Go to line number
Alt+S Split a line

Alt+J Join a line

Alt+L Select a line
Alt+R Select a rectangle
Ctrl+Z Undo

Ctrl+Y Redo

Ctrl+S Save

Ctrl+M Match
Ctrl+Shift+M | Find match
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Internet Resources

% Web page:
>

% Newsgroup:
» news.software.ibm.com/ibm.software.websphere.studio400

% Mailing list:
» To subscribe, unsubscribe, or change list options, visit:
* http://lists.midrange.com/mailman/listinfo/wdsci-I
» or email: WDSCI-L-request@midrange.com

» Before posting, please take a moment to review the archives at
http://archive.midrange.com/wdsci-I
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