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Agenda

♣ PDM Beginnings & How to start in RSE
♣ Table View
♣ Running commands
♣ Compiling
♣ Searching iSeries files
♣ Basic editing with SEU & LPEX
♣ LPEX Syntax checkers, verifiers and outline views
♣ Other LPEX tricks & features
♣ Comparing source

♣ Questions
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Starting with PDM

♣ There are two ways to start PDM:
STRPDM, or

WRKxxxPDM commands

♣ Only the last entries are
remembered

♣ Work with multiple programs,
libraries etc, you might have more
than one emulator running so you
can work with all your items at the
same time
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How to begin in RSE

♣ When you first start WDSC
workbench, you will be prompted
for a workspace.  This is where all
the definitions of your RSE
preferences and workbench
configuration information and files
will reside.

♣ Once the workbench is started,
ensure that you are in the Remote
System Explorer Perspective

Window->Open Perspective-
>Remote System Explorer

♣ Next you will need a connection…
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Creating a connection

♣ Expand the iSeries icon in the New
Connection Filter

♣ Leave the default profile name
♣ Specify host name and connection

name
♣ Ensure Verify connection is

selected
♣ Push Finish
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Subsystems

♣ Expanding a connection lists the
subsystems within that connection:

Objects: used to access libraries,
objects and members

Commands: predefined commands
you can use to run against remote
objects.  You can also define
command sets.  Results are logged
in the Commands log view

Jobs: display various jobs, subset
by job attributes, and perform job
operations

IFS Files: explore IFS file an folder
structure and perform actions on
them.

Qshells: lists the active running
qshells for the connection
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Filters

♣ Filters are named lists of items that
you can specify, reuse and share.

♣ Expanding the Work with… items
opens the appropriate filter
creation dialog

♣ Specify the list of libraries, objects,
or members you want RSE to
retrieve.

♣ Give the filter a name
♣ Choose whether or not you want

the filter to be only for the specified
connection

♣ Choose whether or not you would
like to share the filter with others
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Filter Strings

♣ When first created, a filter is created with only one filter string
♣ By modifying the properties of a filter, you can add additional filter strings

In PDM you could only list the members in one source physical file in one library.

In RSE you can use filters and filter strings to list members in different files and
even in different libraries.

♣ In PDM only the last WRKxxxPDM setting is remembered.  In RSE all filters
are persisted between sessions.
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RSE Tree View

♣ Filters appear in the tree view
♣ Drill down like File Explorer in

Windows
♣ Drag & drop, copy, paste, delete

rename actions
♣ Actions appear in popup (right-

click)
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Table View

♣ More comfortable interface for PDM users
♣ Launch table view from RSE Tree view by using the Show in Table View

action
♣ Use the Work with menu option to access list same way as you would using

the WRKxxxPDM commands
♣ Work with menu keeps a small list of previously displayed lists specifications
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Table View Actions

♣ Use the Show in Table action from inside Table View to go from a list of
libraries to a list of objects etc.

♣ A list of familiar PDM Options
♣ Use the User actions menu to create and add your own actions
♣ Double click on member to edit it
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User Actions (F16)

♣ Define your own action
♣ Prompt the command to define and

also optionally when executing
♣ Use the same substitution

variables as PDM and several
more

♣ Specify if the action should refresh
the views

♣ Specify when action applies when
a single object is selected

♣ Specify Invoke once to group the
items into one command execution

♣ Refine them to apply to the
appropriate types (add your own)
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Command Line

♣ Use the command line to run any command
♣ Specify additional parameters for PDM Options
♣ Results displayed in the messages field
♣ Use familiar keys:

F9: repeat last command

F4: prompt command
♣ Use the Show Log button to view iSeries commands Log view.
♣ Use the STRRSESVR command to handle interactive commands
♣ Batch option uses the SBMJOB command
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Compiling (option 14,15)

♣ Compile actions are grouped in two
menus (with and without
prompting)

♣ Users can add their own
commands to the compile
commands

♣ Compile actions are different from
other actions:

Results of the command itself
appear in the Command Log

Errors appear in the  Error List
view

♣ Additional command execution
preferences can be found in the
Window->Preferences->Remote
Systems->iSeries->Command
Execution preference page (F18)
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Searching (Option 25)

♣ Two ways to search:
Search->iSeries menu

Find String… action
♣ Search filters, not just libraries,

files, members.  This means that
you can create very flexible search
patterns.

♣ Results appear in the Remote
Search view.

♣ Double click on a result to open the
member in Remote Systems LPEX
Editor and position to the match

♣ The popup menu for the members
in the list has similar actions to the
table view (rename, move, etc)

♣ View has a history of searches
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Launching Remote Systems LPEX Editor

♣ From RSE, or Table view:
Double-click

Open (option 2), or

Browse (option 5) using menus

♣ Tokenization: the colouring of
language tokens

♣ Prefix area: can use all the SEU
commands

♣ Show date:  use the context menu
♣ Outline view: shows the outline of

your program.  Used to navigate
within your program
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Remote Systems LPEX Editor vs SEU Basics

♣ SEU
Full screen mode when browsing
(F13)

Split screen and browse

Date area: at the right

Print: STRSEU and Option 6

♣ Remote Systems LPEX Editor
Full screen mode for both edit and
browse: double click on editor tab

Split screen for edit and browse:
there are two options

•Drag and drop the editor tab to
view two different members
•Use editor popup or Ctrl+2 to
split the current LPEX view to
work with different parts of  the
same member (up to 5 splits)

Date appears next to sequence
numbers.  Can be enabled by a
preference or by popup

Print: from File Menu or Ctrl+P
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Split Screens And Date Area

© 2006 IBM Corporation



IBM Software Group  |  WebSphere software

Syntax Checking, Help & Prompting

♣ RSE, like SEU has auto-syntax
checking

See all the errors, not just the first
one

♣ Help (F1) is available for the errors,
but also for the source!

Context sensitive help directly
linked to the reference manuals

Manuals quickly accessible from
the Source menu

♣ Prompting (F4) appears either in
the iSeries Source Prompter view
or (for CL) in a dialog.  F1 context
sensitive help available from the
prompt view or the CL prompter.
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Verifiers & Error List

♣ COBOL, RPG & DDS have a program
verifier (Ctrl+Shift+V)

♣ Syntax & semantic checking (no code
generation)

♣ Verifiers generate the same error
messages as the compiler

♣ Use Source->Verify (Prompt) to specify
additional options or modify default
verify preferences.

♣ Errors appear in the Error List View as
for compile.

Insert errors into source

F1 help for errors

Filter errors

Use as a TODO list

In editor,
•use Ctrl+F5 to Refresh (removes all
errors, clears any excluded lines), or
•Source->Remove messages to
remove errors
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Content assist and Templates

♣ Content assist (Ctrl+Space): propose, display and insert code completions at
the cursor position

Can be used to provide context information

RPG: Refresh the outline view

♣ Templates: type the name of the template and press Ctrl+Space
Add your own templates
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RPG Wizards

♣ Three RPG wizards available to
facilitate programming:

D Specification Wizard

Procedure Wizard

Java Method Call Wizard

♣ Accessed via Source menu or by
popup in source and selecting
appropriate option in the New
submenu

♣ Specify all needed information
using a graphical interface and
source is then generated
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Additional LPEX parser options and features

♣ Preferences
Column sensitive editing

Signatures

Auto-uppercasing

Auto-indent

Auto-formatting

Enter Key behaviour

♣ Parser specific functions:
Open copy member/book

Convert to free form (RPG)

Convert to ILE (RPG)

Show indentation (RPG)
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Compiling from Remote Systems LPEX

♣ Ctrl+Shift+C runs the default compile command
♣ Toolbar button for compiling
♣ Toolbar buttons for next (Ctrl+Shift+H) and previous error (Ctrl+Shift+Y)
♣ Compile menu is available to select
♣ Must be connected to compile
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Jobs

♣ Use the tree view to see jobs
♣ Add to the iSeries Job Status view

by job, or by default using the
preferences

♣ Access job information, properties
using popup

♣ Perform other basic operations
such as end, display job log

♣ Debug and add user actions too
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Search and Replace in LPEX

♣ Ctrl+F bring up the Find function in LPEX (ctrl
♣ Specify search string, and optionally replace string
♣ Specify Regular expression to allow you to search for a pattern:

this|that  (search for this or that)

♣ Ensure column sensitive editing is on, if you don’t want your text shifted
♣ Use Ctrl+N or Shift+F4 to find next match
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Printing (Option 6)

♣ Ctrl+P, print button, File->Print
♣ Various print options can be found

in
Window->Preferences->LPEX
Editor->Print

♣ Note that line numbers are not the
same thing as sequence numbers

♣ Substitution variable allowed in the
header & footer:

%p: page number

%n: source name, base file name,
or document name

%f: full-path file name or document
name

%d: date

%t: time
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Compare (Option 54)

♣ Open member
Edit->Compare->Compare to file

Compare button in toolbar

♣ Source appears merged with differences
flagged in different colours

♣ Only permitted to modify the source that
is opened

♣ Ctrl+Shift+N for next mismatch
♣ Ctrl+Shift+P for previous mismatch
♣ Specify any preferences in LPEX:

Columns to include

Ignore sequence numbers

Ignore blanks

♣ Ctrl+Sift+R to refresh the compare
♣ Edit->Compare->Clear to end
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Additional Useful LPEX Keys

Select a rectangleAlt+R

UndoCtrl+Z

RedoCtrl+Y

SaveCtrl+S

MatchCtrl+M

Find matchCtrl+Shift+M

Select a lineAlt+L

Join a lineAlt+J

Split a lineAlt+S

Go to line numberCtrl+L

Go to the endCtrl+End

Go to the topCtrl+Home
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Internet Resources

♣ Web page:
 www.ibm.com/software/awdtools/wdt400

♣ Newsgroup:
 news.software.ibm.com/ibm.software.websphere.studio400

♣ Mailing list:
 To subscribe, unsubscribe, or change list options, visit:

• http://lists.midrange.com/mailman/listinfo/wdsci-l

 or email: WDSCI-L-request@midrange.com

 Before posting, please take a moment to review the archives at
http://archive.midrange.com/wdsci-l
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